Get SpatialOS

Sites

Menu

Upgrade to the new Runtime

The new Runtime is available from SpatialOS version 13.4.

The new Runtime is made up of the new bridge, the new load balancer, and the new entity database. You need to upgrade to each of these in order.

Upgrading to the new Runtime lets you use the new query-based interest feature. With query-based interest, you specify interest based on the components you’re authoritative over, using queries. You can use these queries to express precisely which components on other entities you are interested in, meaning that the worker only receives updates relevant to what it is simulating.

We encourage you to upgrade your projects to the new Runtime and to use this configuration going forward. This means you’ll be using the version of the Runtime that’s most performant at scale and easiest to scale.

Soon we’ll make the new Runtime the default option and deprecate the old one. Until then, if you want to use the new Runtime, you need to upgrade your bridge, load balancer, and entity database.

After we make the new Runtime the default option, there’ll be a short opt-out window in which you can still use the old Runtime, but after that we’ll stop supporting it altogether.

Search results

Was this page helpful?

Thanks for letting us know!

Thanks for your feedback

Need more help? Ask on the forums